Minggu, 10 Juni 2012



Enhanced Interior Gateway Routing Protocol (EIGRP)

1.  Konfigurasi EIGRP

EIGRP merupakan pengembangan dari Interior Gateway Routing Protocol (IGRP) yang memiliki jumlah Maksimum hop sebanyak 255 hop, dibandingakan dengan Routing Information Protocol (RIP) yang hanya memiliki jumlah maksimum hop sebanyak 15 hop.

Ini adalah topologi yang gunakan dalam setting EIGRP kali ini
Berikut langkah-langkah dalam mengkofigurasikan EIGRP :
  • ·          Memasukkan IP Address pada Masing-masing Interface

Router 1
R1(config)#int fa0/0
R1(config-if)#ip add 172.16.10.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int ser2/0
R1(config-if)#ip add 172.16.20.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shut
R1(config-if)#exit

Router 2
R2(config)#int fa0/0
R2(config-if)#ip add 172.16.30.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int ser2/0
R2(config-if)#ip add 172.16.20.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit


  • ·                                 Setting IP address pada PC

PC 1
IP Address          172.16.10.10
SM                         255.255.255.0
PC 2
IP  Address         172.16.30.30
SM                         255.255.255.0
  • ·                                  Mengkonfigurasi EIGRP pada masing-masing router yang ada.

Setelah itu kita akan mengkonfigurasi EIGRP pada masing-masing router yang ada.

Router 1
R1(config)#router eigrp 100
R1(config-router)# network  172.16.0.0 0.0.0.255
R1(config-router)#  network 172.16.20.0 0.0.0.255
R1(config-router)#  network 172.16.10.0 0.0.0.255
R1(config-router)#no auto-summary
R1(config-router)#variance 1
R1(config-router)#^z
R1#

Router 2
R2(config)#router eigrp 100
R2(config-router)# network 172.16.0.0 0.0.0.255
R2(config-router)#  network 172.16.20.0 0.0.0.255
R2(config-router)# network 172.16.30.0 0.0.0.255
R2(config-router)#no auto-summary
R2(config-router)#variance 1
R2(config-router)#^z
R2#


  • ·                                 Melakukan Proses Authentication

Konfigurasi Router 1 (Austin)

R1#conf t
R1(config)#key chain jarkom
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string cisco
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#interface s2/0
R1(config-if)#ip authentication mode eigrp 100 md5
R1(config-if)#ip authentication key-string eigrp 100 jarkom
R1(config-if)#^z
R1#

Konfigurasi Router 2 (Houston)

R2#conf t
R2(config)#key chain jarkom
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string cisco
R2(config-keychain-key)#exit
R2(config-keychain)#exit
R2(config)#interface s2/0
R2(config-if)#ip authentication mode eigrp 100 md5
R2(config-if)#ip authentication key-string eigrp 100 jarkom
R2(config-if)#^z

  • Memeriksa Koneksi dengan Perintah Ping 

PC1     


PC2


 
  • Memeriksa Koneksi dengan Perintah  show ip route

 Router 1 (Austin)
Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.10.0 is directly connected, FastEthernet0/0
C       172.16.20.0 is directly connected, Serial2/0
D       172.16.30.0 [90/20514560] via 172.16.20.2, 00:07:52, Serial2/0

Router 2 (Houston)
Router# sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 3 subnets
D       172.16.10.0 [90/20514560] via 172.16.20.1, 00:09:19, Serial2/0
C       172.16.20.0 is directly connected, Serial2/0
C       172.16.30.0 is directly connected, FastEthernet0/0



2.  Konfigurasi RIP

  • ·                                   Memasukkan IP Address pada Masing-masing Interface
Router 1
R1(config)#int fa0/0
R1(config-if)#ip add 172.16.10.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int ser2/0
R1(config-if)#ip add 172.16.20.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shut
R1(config-if)#exit

Router 2
R2(config)#int fa0/0
R2(config-if)#ip add 172.16.30.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int ser2/0
R2(config-if)#ip add 172.16.20.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit


·                                 Setting IP address pada PC
PC 1
IP Address          172.16.10.10
SM                         255.255.255.0
PC 2
IP  Address         172.16.30.30
SM                         255.255.255.0

  • ·                                     Mengenalkan Masing-masing Jaringan dengan Menggunakan Router Statis

R1(config)#ip route 172.16.30.0 255.255.255.0 172.16.20.2
R1(config)#end

R2(config)#ip route 172.16.10.0 255.255.255.0 172.16.20.1
R2(config)#end


  •  Memeriksa Koneksi dengan Perintah  show ip route

Router 1 (Austin)
Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.10.0 is directly connected, FastEthernet0/0
C       172.16.20.0 is directly connected, Serial2/0
S       172.16.30.0 [1/0] via 172.16.20.2


Router 2 (Houston)
Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 3 subnets
S       172.16.10.0 [1/0] via 172.16.20.1
C       172.16.20.0 is directly connected, Serial2/0
C       172.16.30.0 is directly connected, FastEthernet0/0














Minggu, 27 Mei 2012

JARKOM 3

SUMMARIZATION

Konfigurasi PC

PC 1
IP Address            172.16.3.2 
Subnet Mask         255.255.255.0
PC 2
IP Address            172.16.1.2
Subnet Mask         255.255.255.0
PC 3
IP Address            192.168.2.2
Subnet Mask         255.255.255.0


Konfigurasi Router

R1(config)#int fa0/0
R1(config-if)#ip add 172.16.3.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int ser2/0
R1(config-if)#ip add 172.16.2.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit

R2(config)#int fa0/0
R2(config-if)#ip add 172.16.1.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int ser2/0
R2(config-if)#ip add 172.16.2.2 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int ser3/0
R2(config-if)#ip add 192.168.1.2 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)#no shut
R2(config-if)#exit

R3(config)#int fa0/0
R3 (config-if)#ip add 192.168.2.1 255.255.255.0
R3 (config-if)#no shut
R3 (config-if)#exit
R3 (config)#int ser2/0
R3 (config-if)#ip add 192.168.1.1 255.255.255.0
R3 (config-if)#no shut




IP Route
R1(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.2
R1(config)#ip route 192.168.0.0 255.255.252.0 172.16.2.2
R1(config)#end

R2(config)#ip route 172.16.3.0 255.255.255.0 172.16.2.1
R2(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.1
R2(config)#end

R3 (config)#ip route 172.16.0.0 255.255.252.0 192.168.1.2
R3 (config)#end

MEMASUKKAN PERINTAH

  • Perintah Ping
  • PC1

PC2

PC3


  • Perintah traceroute




Router 1
R1#traceroute 172.16.1.0
Type escape sequence to abort.
Tracing the route to 172.16.1.0
  1   172.16.2.2      6 msec    6 msec    3 msec   
R1#traceroute 172.16.2.0
Type escape sequence to abort.
Tracing the route to 172.16.2.0
  1   172.16.2.2      6 msec    1 msec    4 msec   
R1#traceroute 192.168.2.0
Type escape sequence to abort.
Tracing the route to 192.168.2.0
  1   172.16.2.2      5 msec    5 msec    5 msec   
  2   192.168.1.1     8 msec    10 msec   6 msec
Router 2
R2#traceroute 172.16.3.0
Type escape sequence to abort.
Tracing the route to 172.16.3.0
  1   172.16.2.1      7 msec    2 msec    5 msec   
R2#traceroute 192.168.2.0
Type escape sequence to abort.
Tracing the route to 192.168.2.0
  1   192.168.1.1     2 msec    4 msec    4 msec  
Router 3
R3#traceroute 172.16.3.0
Type escape sequence to abort.
Tracing the route to 172.16.3.0
  1   192.168.1.2     7 msec    3 msec    3 msec   
  2   172.16.2.1      5 msec    6 msec    5 msec   
R3#traceroute 172.16.1.0
Type escape sequence to abort.
Tracing the route to 172.16.1.0
  1   192.168.1.2     6 msec    6 msec    3 msec   
R3#

  • Show IP Route
Router 1
R1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
     172.16.0.0/24 is subnetted, 3 subnets
S       172.16.1.0 [1/0] via 172.16.2.2
C       172.16.2.0 is directly connected, Serial2/0
C       172.16.3.0 is directly connected, FastEthernet0/0
S    192.168.0.0/22 [1/0] via 172.16.2.2
               
Router 2
R2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
C       172.16.2.0 is directly connected, Serial2/0
S       172.16.3.0 [1/0] via 172.16.2.1
C    192.168.1.0/24 is directly connected, Serial3/0
S    192.168.2.0/24 [1/0] via 192.168.1.1
Router 3
                R3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
     172.16.0.0/22 is subnetted, 1 subnets
S       172.16.0.0 [1/0] via 192.168.1.2
C    192.168.1.0/24 is directly connected, Serial2/0
C    192.168.2.0/24 is directly connected, FastEthernet0/0

  • Show ip interface brief
R1#sh ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        172.16.3.1      YES manual up                    up
FastEthernet1/0        unassigned      YES unset  administratively down down
Serial2/0              172.16.2.1      YES manual up                    up
Serial3/0              unassigned      YES unset  administratively down down
FastEthernet4/0        unassigned      YES unset  administratively down down
FastEthernet5/0        unassigned      YES unset  administratively down down
Router 2
R2#sh ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        172.16.1.1      YES manual up                    up
FastEthernet1/0        unassigned      YES unset  administratively down down
Serial2/0              172.16.2.2      YES manual up                    up
Serial3/0              192.168.1.2     YES manual up                    up
FastEthernet4/0        unassigned      YES unset  administratively down down
FastEthernet5/0        unassigned      YES unset  administratively down down
Router 3
R3#sh ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        192.168.2.1     YES manual up                    up
FastEthernet1/0        unassigned      YES unset  administratively down down
Serial2/0              192.168.1.1     YES manual up                    up
Serial3/0              unassigned      YES unset  administratively down down
FastEthernet4/0        unassigned      YES unset  administratively down down
FastEthernet5/0        unassigned      YES unset  administratively down down


  • Show cdp neighbors detail
Router 1
R1#sh cdp neighbors detail
Device ID: Switch
Entry address(es):
Platform: cisco 2950, Capabilities: Switch
Interface: FastEthernet0/0, Port ID (outgoing port): FastEthernet0/2
Holdtime: 142
Version :
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE SOFTWARE(fc1)
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 18-May-05 22:31 by jharirba
advertisement version: 2
Duplex: full
---------------------------
Device ID: R2
Entry address(es):
  IP address : 172.16.2.2
Platform: cisco PT1000, Capabilities: Router
Interface: Serial2/0, Port ID (outgoing port): Serial2/0
Holdtime: 142
Version :
Cisco Internetwork Operating System Software
IOS (tm) PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang
advertisement version: 2
Duplex: full
Router 2
R2#sh cdp neighbors detail
Device ID: Switch
Entry address(es):
Platform: cisco 2950, Capabilities: Switch
Interface: FastEthernet0/0, Port ID (outgoing port): FastEthernet0/2
Holdtime: 143
Version :
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE SOFTWARE(fc1)
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 18-May-05 22:31 by jharirba
advertisement version: 2
Duplex: full
---------------------------
Device ID: R1
Entry address(es):
  IP address : 172.16.2.1
Platform: cisco PT1000, Capabilities: Router
Interface: Serial2/0, Port ID (outgoing port): Serial2/0
Holdtime: 152
Version :
Cisco Internetwork Operating System Software
IOS (tm) PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang
advertisement version: 2
Duplex: full
---------------------------
Device ID: R3
Entry address(es):
  IP address : 192.168.1.1
Platform: cisco PT1000, Capabilities: Router
Interface: Serial3/0, Port ID (outgoing port): Serial2/0
Holdtime: 151
Version :
Cisco Internetwork Operating System Software
IOS (tm) PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang
advertisement version: 2
Duplex: full
Router 3
R3#sh cdp neighbors detail
Device ID: Switch
Entry address(es):
Platform: cisco 2950, Capabilities: Switch
Interface: FastEthernet0/0, Port ID (outgoing port): FastEthernet0/1
Holdtime: 143
Version :
Cisco Internetwork Operating System Software
IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE SOFTWARE(fc1)
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 18-May-05 22:31 by jharirba
advertisement version: 2
Duplex: full
---------------------------
Device ID: R2
Entry address(es):
  IP address : 192.168.1.2
Platform: cisco PT1000, Capabilities: Router
Interface: Serial2/0, Port ID (outgoing port): Serial3/0
Holdtime: 143
Version :
Cisco Internetwork Operating System Software
IOS (tm) PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang
advertisement version: 2
Duplex: full